Application: SLAnalyzer
Description: Diagnostic tool provided by Micro Focus support
Current version: 9.0.1.3
Download location: https://ftp.novell.com/pub/SLAnalyzer/SLAnalyzerChromium.new

9.0.1.3
- Added new SSPR forgotten password API to SSPR REST client
- Fixed crash if user did not enter SSPR REST client Post signing form data
- Fixed issue where Azure no longer allows TLS 1.1 or lower connections. Changed Tools->Azure to require TLS 1.2 connection.
- Fixed issue where AAF enroll OTP failed to display QRCode.

9.0.1.2
- Fixed focus issue when double clicking on a folder in SSH/SCP explorer
- Fixed filtering issue after clicking analyze on opened generic text file
- Modified AAF REST client – Administrative enrollment of PKI to include subject
- Redesign of AAF REST client – Automated process - Enroll 
- Changed SSH/SCP Explorer – Docker image run option for same syntax as host run option.
- Added option in Web Browser to clear local browser cache
- Updated to support new docker naming convention for 6.4 AA servers. Trap for underscore -vs- dash characters. IE. aaf_aucore_1 or aaf-aucore-1

9.0.1.1
- Modified LDAP client to display results for search results too large responses from LDAP server
- Added additional tooltip information for LDAP search filter syntax to include examples for searching for smaller subset of data
- Added check and installation of Microsoft Webview2 runtime

9.0.1.0
- Changed embedded browser from CEF to WebView2 class

9.0.0.19
- Added Linux zypper history log file parser
- Added Tools->Common Appliance Framework->Update Appliance
- Added zypper logs to Tools->Common Appliance Framework->Get Registration Logs
- Added AA REST Client - Show Override Auto Enrollment

9.0.0.18
- Added AA debug log parser for AAF support bundle logs.
- Added AA REST Client – Generate Support bundle - EventCategories 
- Added AA REST Client – Generate Support bundle - CustomLocales 
- Added AA REST Client – Generate Support bundle – CustomMessages
- Added AA REST Client – Generate Support bundle – UserLogon
- Added AA REST Client – Generate Support bundle – ServerStatus
- Fixed crash in file parser when loading zypper.log
- Changed generic log parser to no longer display unused time and module columns 

9.0.0.17
- Added file parsers for AA debug logs celery, async, root, uwsgi, and nginx error logs.
- Fixed SSPR log file parser when detected within Catalina log file.
- Added Tools->Advanced Authentication->REST client automated function Register Method for User

9.0.0.16
- Changed Tools/Advanced Authentication/REST Client (Generate Support Bundle) to no longer require an endpoint session.
- Modified SSH Explorer server properties to use netstat -ant to show listening and established port information.
- Changed automated function “Show Shared Template Info” to Tools->Advanced Authentication->REST Client to auto select the Helpdesk event for login.
- Fixed potential crash when attempting to find text within a text window.

9.0.0.15
- Added new tool SSH Explorer to Tools->SSH/SCP
- Added new tool Advanced Authentication->Replace OSP Certificates
- Added option to restart host in Tools->SSH/SCP menu
- Added the ability to run files from Kubernetes Node explorer
- Added the ability to modify permissions within the Kubernetes Node explorer

9.0.0.14
- Fixed app crash when SLAE server does not have auditing configured
- Added run menu option to Azure Kubernetes Node explorer
- Added Get IP Address to Tools->Azure
- Added IP address information to Initialize Kubernetes
- Added automated function “Show Shared Template Info” to Tools->Advanced Authentication->REST Client

9.0.0.13
- Fixed Tools->Advanced Authentication->OSP/OAuth2 
- Added ability to select target browser to OSP/OAuth2 window

9.0.0.12
- Changed Azure->Get Kubernetes Logs to limit logs to last hour
- Minor bug fixes

9.0.0.11
- Add profile section to Azure login windows.
- Added support for Azure Kubernetes containers
- Extended Initialize Kubernetes to support non-SLAE configurations

9.0.0.10
- Bug fix for Tools->Advanced Authentication->REST Client. Get debug status fails unless get support bundle was selected first.

9.0.0.9
- Added Tools->Azure->Kubernetes Node Explorer
- Updated User Interface icons 

9.0.0.8
- Fixed Tools->Azure->Send File to support files larger than 50k bytes
- Changed Tools->Azure->KubeCtl Terminal to use /bin/bash -c
- Changed Tools->Azure->KubeCtl Terminal for remembering commands (up/dwn keys)

9.0.0.7
- Added SecureLogin Advanced Edition repository to SecureLogin analysis report
- Added Azure option to Tools Menu
- Added Azure->Azure AD Login
- Added Azure->Azure Client Login
- Added Azure->SecureLogin Advanced Edition Login
- Added Azure->Get Subscriptions
- Added Azure->Get Resources
- Added Azure->Get Kubernetes Info
- Added Azure->Get Kubernetes Name Space
- Added Azure->Get Kubernetes Pods
- Added Azure->Get Kubernetes Logs
- Added Azure->Initialize for Kubernetes
- Added Azure->KubeCtl Terminal
- Added Azure->Get File
- Added Azure->Send File
- Added Azure->Send Command
- Added Azure->Get
- Added Application folder information to about box
- Fixed JSON file parser not parsing complete file
- Fixed Missing mono file in installation package (certmgr.exe)
- Fixed Missing Chromium files in installation package (chrome_100_percent.pak) and (chrome_200_percent.pak)
- Changed Analyze->Advanced Authentication to perform SRV lookup even when AA client is not installed.

9.0.0.6
- Fixed issue with json viewer not saving data correctly to file

9.0.0.5
- Fixed AAF REST client (Generate Support Bundle) for multi-tenant

9.0.0.4
- Add Common Appliance Framework->Generate Support Config

9.0.0.3
- Enhanced AAF REST client for multi-tenant
- Added SaaS option to tools menu
- Added AAF CBA options to SaaS menu
- Added SaaS->CBA->Gather CBA Statistics
- Added SaaS->CBA->Start CBA
- Added SaaS->CBA->Stop CBA
- Added SaaS->CBA->Debug Settings
- Added SaaS->CBA->Get Install logs
- Added SaaS->CBA->Get Debug logs
- Added AAF REST call READ ALL CUSTOM MESSAGES FOR CATEGORY
- Added AAF REST call READ CUSTOM MESSAGES ITEM FOR CATEGORY AND KEY
- Added AAF REST call ENROLL NEW TOTP
- Added AAF REST call AUTHENTICATE BY BASIC AUTHENTICATION HEADER
- Added AAF REST call REGISTER LOGON DOMAINS FOR THE CURRENT TENANT
- Added AAF REST call LOGON DOMAINS LOOKUP
- Added AAF REST call GET OTP TOKENS WITH PAGINATION
- Added AAF REST call CREATE OTP TOKEN
- Added AAF REST call GET OTP TOKEN
- Added AAF REST call DELETE OTP TOKEN
- Added AAF REST call ENROLL OTP TOKEN
- Added AAF REST call REVOKE OTP TOKEN
- Added AAF REST call Device manager->Touchid
- Added AAF REST call Device manager->WinHello
- Added AAF Token Manager
- Fixed an intermittent error in retrieving AAF PostGres DB credentials

9.0.0.2
- Add new SLAnalyzer download manager so that auto update feature in old versions will still work
- Add opensource license information to about box
- Add Links button to Tools->Web Browser

9.0.0.1
- Add Chromium Browser support
	Web Browser under tools menu now Chromium based
	Links opened within SLAnalyzer now utilize new Chromium libraries

- New Installation package for SLAnalyzer utility

8.8.1.13 
- Advanced Authentication: Add CA Root certificate 
Allows the ability to add a root certificate from customer local CA
- HAR file analysis replay
Adds the ability to replay packets seen in HAR file analysis

8.8.1.6
- Restructure of Tools menu
- Add Common Appliance Framework: Reset Appliance Certificate
- Add Advanced Authentication: Reset Local Admin PWD
This option works for AAF 6.3 SP3 and later. It allows the reset of the local\admin user password
- Add Advanced Authentication: Gather Server Stats
Will generate a report similar to the IDM report included in the IDM support bundle. 
- Add Advanced Authentication: Monitor server performance
There are 4 options. 
	Add will add the cronjob 
	Check will report the active cronjobs 
	Remove will remove the cronjobs 
	Download logs will download all the logs created by the cronjob to a single zip.

- SSH/SCP
Provides 3 options
	Basic SSH terminal - This is a simple implementation without many features. The purpose is to provide a quick mechanism to run commands or other processes. For full support it would be suggested to use a real SSH utility. 
	Download File - Will use SCP to download a file from the server. Note that you must provide the path and filename to the file to download. 

Upload File - Will use SCP to upload a file to the server in the path specified.

8.8.1.2
- Add support for analyzing HAR files
- Full support for IDM REST APIs
- Add SSH client and features

8.8.1.1
- Identity Manager: Get IDM Support bundle
	Adds the ability to generate a report containing IDM server diagnostics


8.8.0.17
- Initial release of HAR file support
	Selecting content from HAR file analysis provides ability to view or download content from packet data


8.8.0.12
- Advanced Authentication: Enhance REST Client API List Users to allow user to specify page #.
- Advanced Authentication: Enhance REST Client API Build AAFDB to continue build after failure

8.8.0.11
- Advanced Authentication: REST client update to add profiling
https://www.netiq.com/documentation/advanced-authentication-63/server-administrator-guide/data/t4byj6vrd1gh.html

8.8.0.3
- Add RISK services API's

8.6.1.11
- Add ability to export logs to csv format

8.6.1.7
- Reworked the AAF REST client
- Add Analyze for AAF Client and configuration

8.6.1.4
- Add support for PostGreSQL to SQL Browser under tools menu

8.6.1.2
- Add auto update feature
- Add MySQL support to Tools->SQL Browser

8.6.1.0
- Add support for SecureLogin 8.6.1
- Advanced Authentication
Added 5 new AAF REST calls. 
	List of Events 
	Create Event 
	Get Event by Event ID 
	Update Event 
	Delete Event


	Added Generate support bundle

Updated AAF Links to mirror appliance console

3.0.0.0
- Add OAuth2 option under tools menu
- Add SQL Browser under tools menu
- Add LDAP Browser to tools menu

2.0.2.17
- Added links to help menu

2.0.2.13
- Add SSPR Rights Validator under tools menu

2.0.2.11
- Added new AAF 5.3 events
- Bug fix for detecting newer AAF 5.x APIs

2.0.2.10
- Add support for AAF 5.3

2.0.2.4
- Add support for ndstrace analysis

2.0.2.3
- Add debug console under tools menu

2.0.2.0
- Add Diff Viewer under tools menu

2.0.1.7
- Add GPO data to analysis reports

2.0.1.6
- Add Windows GPO options to tools menu

2.0.1.5
- Adds find menu option to xml and json file viewers
- Adds a check for the ability to encrypt/decrypt files for CLE EA cache file creation
- Fixes a number of formatting issues with NSL report.

2.0.0.13
- For REST tools popup certificate details. 
- Add tracing under SLAnalyzer settings menu to trace DotNeT HTTP traffic.

2.0.0.12
- Bug fix for error displayed if default report folder was missing

2.0.0.8
- Add the open and saveas dialogs to the LDAP export in LDAP Browser
- AAF REST Client updates
	Build method database 
	open AAF database options. This allows for customers to perform multiple exports and imports to separate files or merged into a single AAF method database. 
	Fixed the file/open AAF database to support the right click context menu for copy/find/jump menu. 

- Log viewer update
	Fixed the ability to filter on any displayed column


2.0.0.7
- Add support to generate a report of AAF users and enrolled methods

2.0.0.6
- Adds support for AAF 5.1.3 API changes and the TOTP method

2.0.0.1
- Fixes for NAAF REST Client
	Enroll SmartCard QR code window was not movable. Would popup in weird locations. 
	Advanced, enroll no longer saves profile by default 
	Advanced, assign user template now works 
	Advanced, update user template now works 
	Advanced, delete user template now works

- Fixes for SSPR REST Client
	SSPR debug log no longer strips the commas from the message field 
	Filter modules read dynamically when log file is loaded 
	SSPR REST client, user can specify full path to non-default installation paths (IE /sspr32)


2.0.0.0
- Rebrand from Novell to Micro Focus
- Add AAF 5.x REST Client
- Rework SSPR REST Client
	Allow full URL to be specified 
	Clean up JSON data


1.0.10.10
- Fix crash when closing SLAnalyzer version 1.0.10.7 due to attempt to cleanup temp files when they didn't exist

1.0.10.4
- Add support to open compressed files
- Adds support for XML files
- Adds LDAP Browser to Tools menu

1.0.10.2
- Adds Analysis of CLE installations
- Adds SSPR REST Client

1.0.9.4
- Add ability to specify Log File path

1.0.8.1
- Bug fixes
- Enhanced analysis reports

1.0.6.6
- Bug fixes

1.0.6.0
- Open debug log for analysis
- Filter debug log for error state values (Errors, Warnings, Information)
- Filter debug log on specific SecureLogin module
- Copy lines from log to system copy/paste buffer
- Search debug log for specified text
- Enable/Disable debug logging on host computer
- File Browser to view SecureLogin files on workstation
- Registry Browser to view SecureLogin related registry keys
- Make configuration reports more granular. User now has the ability to select the type of report to generate. All runs all reports 
- Configuration Report to generate information about the host computer. This includes hardware/software/directory mode and diagnostics/NSL client configuration and diagnostics.

1.0.5.0
- Add support for SecureLogin 8
- Dropped support for Windows XP

1.0.0.0
- Initial release
- Supported SecureLogin log file analysis
- Supported SecureLogin version 7

